Posts Tagged ‘exchange2003’

Popular posts created in 2009 from Absoblogginlutely.net

Sunday, January 3rd, 2010

Following up from the previous post on most viewed pages of Absoblogginlutely.net in 2009, here are the most popular posts that were written in 2009. All but two of these are solutions to problems that I encountered during the 2009. Some of them were quick google searches, others were based on research and experience but hopefully the solutions have helped others in the same situation that I’ve been in.

  1. Firewall exception requirements for Symantec Endpoint Protection
  2. MYSql failed to install with the most recent install package
  3. Skype plugin caused firefox to slow down
  4. How to install 32bit print drivers on a Windows 64bit server
  5. Windows7 upgrade advisor failed to work
  6. Archiving an Exchange2007 mailbox using Powershell
  7. Fix to Exchange2003 NDR’s being delivered weeks after the mail failed.
  8. Granting Full access to a mailbox allowed me to export from Exchange 2007
  9. Fix to Out Of Office in Outlook 2007 failing
  10. My attempts at dual booting Windows 7 and Windows XP with Truecrypt on the original XP Installation disk

Exchange 2003 NDR’s are sent a long time after email was sent.

Thursday, April 2nd, 2009

The past two reboots (where the server has been offline for a while) has resulted in non delivery reports being sent back to some of the mailboxes for mail that was sent several weeks ago and that had not been reported as failed when the mail was initially sent.
The first time this happened I thought it was just one of those things, especially as I had not seen mail in the queue before rebooting the server. After the second occurrence I knew it was time to investigate.
SBSisyphus has a great posting including a link to the exchange2003 (sp2) patch that should fix the “kb950757 Email senders do not receive an indication that some messages have been held by Exchange Server 2003 until the SMTP service, The Microsoft Exchange Information Store service, or the Exchange server is restarted”. I applied it to my machine and I’ll have to see what happens.
For what it’s worth you do not need to reboot the server (unless wmiprvse.exe is running – but you get an option to kill this process if it is running before proceeding) but it will stop and start your mail and web services so don’t apply it during the day and it goes without saying that you should have a backup first.

Fixing exchange2003 unable to send to exchange2007 mailboxes.

Monday, December 1st, 2008

In my newly installed exchange2007 site I also had an exchange2003 server that handles all the incoming/outgoing mail apart from the test user that I had moved to the 2007 server. Unfortunately I could not send mail to the 2007 user but I could receive mail from this user. T here was a lot of postings on the internet and various forums for solutions for a similar problem but normally in the opposite direction.
After a post at petri (2nd posting down) I deleted my smarthost setting on the virtual server on the 2003 machine and mail started flowing. Now I can progress in my mail migration. Many thanks to Andy at Petri for the answer on this one.
Annoyingly this did come up in the best practise analyzer, but only as a warning. As the smarthost had been working I left it alone – I really should have known better.