Fixed – Adobe Reader not opening in ie – turning off Open in browser.

Using Adobe Reader 9.04 on a Windows 2008r2 Remote Desktop server, I was finding that a lot of websites would fail to run when a pdf file was opened in the browser. Going to Edit/Preferences/Internet and unchecking the “Open pdf in browser” fixed the problem. The next problem was making this site wide and for every user on the terminal server.
Using procmon I was able to check the registry changes that occurred when this box was checked (although this does not help when the av software is constantly scanning the registry and files). By creating HKCU\ Software\ Adobe\ Acrobat Reader\ 9.0\ Original\ bBrowserIntegration as a dword and setting the value to 0, this option was checked for everyone. I did notice that the server initially checks HKLM for the same value, but in testing I found that adding this value under HKLM did not make the user interface change. I know Adobe checks other settings in the registry so I’m not sure if it was checking other locations to see if HKLM should also be set, but in that case, why check the HKLM value too?
Using the Group Policy Preferences I was able to create a new setting and now Adobe Reader works for everyone on the server.

Of course, once you know this key it’s easy to find lots of google articles mentioning bBrowserIntegration but I couldn’t find anything when I initially researched this problem. One solution that might make it easier is to download a Adobe Reader Group Policy template which you can then import (computer / Administrative Templates/ Right click and browse) to apply this and other settings. Note that I found the EULA supression did not work for me with Adobe Reader 9.04 on W2k8R2

Leave a Reply

Your email address will not be published. Required fields are marked *