Firefox 3.5 is now out.

I upgraded over lunchtime this afternoon and so far it seems ok. There were several extensions that claim to not be compatible but I’ll be forcing the ignore version check using the Mr Tech Toolkit Extension. To disable the version check, click Tools/Mr Tech Toolkit Settings, select the Miscellaneous tab, XPI Install Options and then uncheck “Enable Addons Compatability checking” and optionally enable “Disable XPI install time delay” so you don’t get bugged by the delay each time you want to install an addon.

The plugins that didn’t work were Better flickr 0.3, better gmail 2.0.8.1, Better greader 0.6.1, bit.ly preview 1.262, firebug 1.3.3 (upgrade was found to 1.4.0.3b), Microsoft Net Framework Assistant 1.0 and New Tab King 1.9.7.

Both Bit.ly, and New Tab King seem to work – I’ve not tried the others yet as I now have to get back to work.

3 thoughts on “Firefox 3.5 is now out.

  1. Thanks Eddie. For some reason my extension has not checked for an update since 1.9.7. I think this is because the others are marked as experimental?

  2. yep – still in experimental (the guys at AMO are exteremly slow at approving our addon) – but feel free to comment and send us feedback.

Leave a Reply

Your email address will not be published. Required fields are marked *