msgina event 1010 errors

Finally managed to solve an issue that has been bugging me for months. A user was logging onto the Terminal server but two of their network drives would not connect as part of the login script. However doing a net use and providing username and password in the prompts would connect (which is how they’ve been connecting for a while). Logging into a local pc worked fine, but logging in via terminal services always had this problem – so it had to be something to do with the roaming terminal service profile.
Eventvwr was showing events Userenv 1030 – Windows cannot query for the list of Group Policy objects, Userenv 1006 – Windows cannot bind to domain.com domain (Invalid Credentials), MsGina 1010 Failed to set the user’s home directory,
I tried debugging using KB221833 which gave me 43 pages of logs to read through.
Eventually I logged into the Terminal server as the user, went into control panel, stored passwords and lo and behold – there was someone elses username (and password). Deleted this stored account, logged off and back on again and got all their network drives connected.
control keymgr.dll is a shortcut to this screen that users might be able to use to clear this themselves.

4 thoughts on “msgina event 1010 errors

  1. WOW, that’s all I can say. This has been a problem for me too, for months. Removing the stored passwords worked. Thanks so much for sharing this info! And thank you Google!

  2. Is there a way I could go to the server and clear out everyone’s passwords from there instead of logging on as each different user and doing it that way?

    Thanks!!

  3. I don’t see a way of doing this although according to Microsoft you can (but they helpfully are very vague in doing so!) According to the Microsoft website article you can disable the stored username and password using group policy but no detail is provided on how to do this. The Group policy excel file that details group policies at http://tinyurl.com/6fpdh does not have this setting detailed in it.

  4. I started having the same error MsGina 1010 Failed to set the user’s home directory and have no stored username and password anywhere. Any other suggestion?

Comments are closed.